配置OCSNG资产管理系统

820views

早就听说GLPI+OCSNG是一对配合极佳的资产管理和IT公司内部管理的开源软件,后来让手下的一个人部署了一下,还没有等实际的推广和应用,这个哥们就辞职了,最近偶收到那个臭名昭著的塞班思审计的问题,虽然这次不是针对IT的,但偶不得不开始具体准备这方面的事情,所以这个OCSNG就有必要马上推广和部署下去,手头没有可用的资源,想想自己来吧,反正也只是个应用,应该不难,整理了一下自己的模板虚拟机 CentOS 5.4就开始了。

从网上搜索了一下,然后上官方网站上看了一下,发现针对CentOS的OCSNG的部署真多啊,甚至CentOS的官方文档里都有,不过我个人觉得CentOS应该不是非常关注某个应用的安装和部署,所以文档肯定不够更新及时,还是OCSNG的官方网站的东西更多一些,那么就开始动手吧。检查了一下自己服务器的配置,CentOS5.4, Mysql5.2, PHP 5.2.x, Apache 2.x都有,Mysql的用户配置都完整,一切准备就绪。

按照官方的文档安装管理服务器应该很方便,都是依据Yum的安装包,可是偶确发现第一步中的:

  • yum install perl-Apache-DBI
  • yum install perl-SOAP-Lite

这两个包没有,百思不得其解,后来发现偶这个yum的标准升级源不行,必须装一些扩展源,为了装这些扩展源还要装一个关于源优先级判定的package,这些都没问题,很快就装过去了,然后把这些扩展模块的源知道rpmforge之后终于抓到和升级了N多Perl的包,这一步过去了,下一步文档中明确要求需要装PHP的zip扩展,我试着用我知道的和文档提供的命令例如 yum install php-pecl-zip, pear install zip等都告诉我现在我用的pear的版本1.4.9太低,需要升到1.7.0, 然后我想用pecl安装,也说偶的pear的版本需要从1.4.9升级到1.5.4先,问题是这已经是偶这个CentOS提供的最高版本,其他的Pear的版本偶还需要自己编译或者找单独的rmp吧,这时候已经到了昨晚下班,回家吃饭先。

今早继续战斗,发现没法解决Pear的版本问题之后偶只能寄希望于自己编译PHP模块,加上带zip的选项就没问题,但仔细看了一下yum的安装dependency,觉得这样风险还是很大,算了,看看有没有zip的rpm吧,去了PHP.NET一看,发现最新的版本上 有个特殊的小标记,说必须pear 1.7支持,而其余的很多版本都没这个标记,那岂不是我的那个pear install zip的错误只是默认要安装最新版本才有的,如果安装低一点的版本呢?赶紧一试,果真好用,哇咔咔,折腾了我四五个小时的问题就此解决。

继续往下,基本都没啥问题,然后开始装管理服务器,一步一步的问题特别多,看过一个文章说,其实全部默认选项就OK,所以我就偷懒,全部回车,一路下去确认了所有模块之后安装,装完之后我就兴冲冲的跑去那个ocsreports目录看webUI的管理界面,但是居然报错,研究了半天居然不明所以然,以为是数据库的错误,试验了数据库半天,无果,回头再去看文档,我晕,居然还需要安装,进入安装界面,两秒种之后大功告成。。

这次安装还是非常顺利的,看来OCSNG的package设计的还是不错,几个错误都是偶不仔细看文档或者没明白命令行的具体含义,唉。。下一步就是测试,然后分发了,估计要明年做了。

相关的文章

2 Responses to “配置OCSNG资产管理系统”

  1. 阿修理

    对了 你ROM集成雅黑是多少MB的
    有的字感觉还是比较毛糙
    我这有个14MB的 比较完美
    要的加我QQ 630525118

    回复

Leave a Reply

will not be published

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据